简讯 | Docker Hub将不再支持1.5和更早版本的客户端


【编者的话】Docker Team邮件简讯:Docker Hub将不再支持客户端为1.5和更早的版本。

亲爱的Docke Hub用户:

去年春天Docker发布了版本 1.6的引擎和版本2的Registry。引入了具有更快镜像传输的推送/拉取协议、简化了镜像定义并且提高了安全性。Docker社区一直在积极采纳他们,结果显示超过99%Docker Hub的使用是基于这些较新版本的。这样一来,我们准备在Docker Hub上不再支持版本1.5和更早版本的客户端。
  • 截止到2015年11月19号,版本1.5和更早版本的Docker客户端将无法将镜像推送到Docker Hub。他们仍然能够拉取镜像。当然较新版本的Docker客户端可以完全访问Docker Hub的仓库。
  • 截止到2015年12月7日,版本1.5和更早版本的客户端拉取镜像也将被禁用。只支持1.6或更高版本。


处理这种迁移非常简单。您所需要做的是升级你的Docker客户端到1.6或更高版本。请务必要升级从你的Docker Hub仓库推送或者拉取镜像的客户端,他们包括那些在开发机器、线上的服务器或者是CI和CD工作流程中的部分的客户端。

如果您有任何问题,请及时与我们联系。

诚挚的问候,

Docker Hub团队

原文链接:Docker Hub deprecation for clients 1.5 and earlier (翻译:田浩浩

1 个评论

哇,这个包袱甩的真快,哈哈

要回复文章请先登录注册