如果用Docker,应用依赖内核版本的问题岂不是无解?


比如我用CentOS7运行Docker,宿主机内核是3.10,那就意味着我的容器内核也是3.10,那如果有应用依赖一些内核功能,比如内核2.6.30什么的,或者需要一些内核模块。如果在容器里操作内核岂不是很危险(和主机公用),
我想问一下,大家在这方面有考虑过有什么比较好的想法么。

QQ20160713-0@2x.png
已邀请:

fastzhong

赞同来自:


Linux内核是向前兼容的,所以你可以安啦,除非你用到第三方附加的东西,如rendhat的东西,然后跑在Ubuntu上,那就没有办法了,但这种情况很少。

要回复问题请先登录注册