k8s 1.3 apiserver 启动失败


从github下载了1.3.5 的命令包,启动命令是`

./kube-apiserver --logtostderr=true --v=4 --etcd-servers=http://SHCLITVM0603.hpeswlab.net:4001 --insecure-bind-address=0.0.0.0 --insecure-port=8080 --allow-privileged=false --service-cluster-ip-range=10.254.0.0/16 --admission-control=NamespaceLifecycle,LimitRanger,ServiceAccount,ResourceQuota --client_ca_file=/var/run/kubernetes/ca.crt --tls-private-key-file=/var/run/kubernetes/server.key --tls-cert-file=/var/run/kubernetes/server.crt --token_auth_file=/etc/kubernetes/token

报错为


E0819 16:52:24.677644 18486 reflector.go:216] k8s.io/kubernetes/plugin/pkg/admission/serviceaccount/admission.go:103: Failed to list *api.ServiceAccount: an error on the server has prevented the request from succeeding (get serviceaccounts)
E0819 16:52:24.677662 18486 reflector.go:205] k8s.io/kubernetes/plugin/pkg/admission/namespace/lifecycle/admission.go:116: Failed to list *api.Namespace: an error on the server has prevented the request from succeeding (get namespaces)
E0819 16:52:24.677708 18486 reflector.go:216] k8s.io/kubernetes/plugin/pkg/admission/serviceaccount/admission.go:119: Failed to list *api.Secret: an error on the server has prevented the request from succeeding (get secrets)
E0819 16:52:24.677883 18486 reflector.go:205] k8s.io/kubernetes/plugin/pkg/admission/limitranger/admission.go:154: Failed to list *api.LimitRange: an error on the server has prevented the request from succeeding (get limitranges)
E0819 16:52:24.678276 18486 reflector.go:205] k8s.io/kubernetes/plugin/pkg/admission/resourcequota/controller.go:121: Failed to list *api.ResourceQuota: an error on the server has prevented the request from succeeding (get resourcequotas)
但是当我把apiserver命令换成1.2 版本的,启动就正常了,如果用1.3的,把启动参数中--admission-control=NamespaceLifecycle,LimitRanger,ServiceAccount,ResourceQuota 去掉时,也能启动,不知为何,有遇到过的吗
已邀请:

ɡōōd洋

赞同来自:


oh ,shit ,居然是由于有http_proxy ,

RobinChen - waj_615@qq.com

赞同来自:


哈哈 非常感谢

行知 - 80后IT男

赞同来自:


也出现了这个问题,请问你后面搞明白没

要回复问题请先登录注册