swarm mode 无法使用calico网络?


[root@docker.swarm01 opt]# docker network create --driver calico --ipam-driver calico-ipam calico-net
Error response from daemon: rpc error: code = 3 desc = legacy plugin calico of type NetworkDriver is not supported in swarm mode

[root@docker.swarm01 opt]# calicoctl version
Version: v1.0.2
Build date: 2017-01-31T04:05:47+0000
Git commit: 7fe3468

[root@docker.swarm01 opt]# docker version
Client:
Version: 17.03.0-ce
API version: 1.26
Go version: go1.7.5
Git commit: 60ccb22
Built: Thu Feb 23 10:54:03 2017
OS/Arch: linux/amd64

Server:
Version: 17.03.0-ce
API version: 1.26 (minimum version 1.12)
Go version: go1.7.5
Git commit: 60ccb22
Built: Thu Feb 23 10:54:03 2017
OS/Arch: linux/amd64
Experimental: false
已邀请:

要回复问题请先登录注册