swarm版本的问题


最近在研究swarm,看docker官方文档,说swarm有docker的集成版和独立版,集成版已经可以使用docker swarm直接使用,独立版还需要自己去启动容器配置,那么一般在生产环境应该使用哪个版本比较稳定,还有如果使用集成的docker swarm,服务发现是不是没有办法配置,因为我想使用consul集群做服务发现
已邀请:

要回复问题请先登录注册