安装kubernetes,提示docker版本不兼容


yum install kubernetes -y

错误:docker-engine conflicts with docker-1.9.1-25.el7.centos.x86_64
错误:docker-engine-selinux conflicts with docker-selinux-1.9.1-25.el7.centos.x86_64

selinux关闭了,我的docker是1.10.3,版本高了还不行?
已邀请:

subchen

赞同来自: aaron3323


用 yum 安装的 kubernetes 依赖的是 docker,不是 docker-engine
所以不建议用 yum 安装

阿拉丁和灯 - 科学主义者,技术人

赞同来自:


试试在安装kubernetes之前先运行 yum -y update

阿拉丁和灯 - 科学主义者,技术人

赞同来自:


或者yum remove docker先把docker删掉,然后再安装kubernetes

要回复问题请先登录注册